Bug 26014

Summary: xulrunner-5.0 must have versioned dependency on xulrunner-libs-5.0
Product: Sisyphus Reporter: Anatoly Lyutin <vostok>
Component: xulrunner-5.0Assignee: Alexey Gladkov <legion>
Status: CLOSED FIXED QA Contact: qa-sisyphus
Severity: blocker    
Priority: P3 CC: aen, gns, mike, radik
Version: unstable   
Hardware: all   
OS: Linux   
Bug Depends on:    
Bug Blocks: 23155    

Description Anatoly Lyutin 2011-08-09 13:00:12 MSK
[vostok@localhost ~]$ firefox                                                                                                                                
Error: Platform version '2.0.1' is not compatible with                                                                                                       
minVersion >= 5.0.1                                                                                                                                          
maxVersion <= 5.0.1  


Снёс полностью firefox, xulrunner, подвинул ~/.mozilla/firfox

Ничего не помогает.
Почините, пожалуйста, firefox :)
Comment 1 Nick S. Grechukh 2011-08-09 14:58:53 MSK
apt> install xulrunner-5.0-libs
Unrequested changes are needed to execute this operation.
The following packages will be REPLACED:
  xulrunner-2.0-libs (by xulrunner-5.0-libs)
The following NEW packages will be installed:

Решает проблему.
Comment 2 Anatoly Lyutin 2011-08-09 15:07:47 MSK
(В ответ на комментарий №1)
> apt> install xulrunner-5.0-libs
>   xulrunner-2.0-libs (by xulrunner-5.0-libs)
> Решает проблему.

Да, спасибо. Не заметил что в Сизифе две версии xulrunner-libs оказалось.
Comment 3 Alexey Gladkov 2011-08-09 17:49:34 MSK
*** Bug 26015 has been marked as a duplicate of this bug. ***
Comment 4 Repository Robot 2011-08-09 23:58:14 MSK
xulrunner-5.0-5.0.1-alt2 -> sisyphus:

* Tue Aug 09 2011 Alexey Gladkov <legion@altlinux> 5.0.1-alt2
- Fix requires (ALT#26014).